Commit 0f9549c5 authored by Matthias Fechner's avatar Matthias Fechner

Update to r526914.

parent 70477509

Too many changes to show.

To preserve performance only 1000 of 1000+ files are displayed.

......@@ -691,6 +691,7 @@ ryusuke = Ryusuke SUZUKI <ryusuke@FreeBSD.org>
sada = SADA Kenji <sada@FreeBSD.org>
sah = Sam Hopkins <sah@FreeBSD.org>
sahil = Sahil Tandon <sahil@FreeBSD.org>
salvadore = Lorenzo Salvadore <salvadore@FreeBSD.org>
sam = Sam Leffler <sam@FreeBSD.org>
samm = Oleksii Samorukov <samm@FreeBSD.org>
sanpei = MIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>
......
#
# MOVED -- A list of (recently) moved or removed ports
#
# $FreeBSD: head/MOVED 526344 2020-02-17 06:29:46Z koobs $
# $FreeBSD: head/MOVED 526913 2020-02-23 10:07:39Z rene $
#
# Each entry consists of a single line containing the following four
# fields in the order named, separated with the pipe (`|') character:
......@@ -14280,3 +14280,110 @@ x11-fm/rox-mime-editor||2020-02-16|Has expired: Old, uses EOLed python27
x11-fm/rox-session||2020-02-16|Has expired: Old, uses EOLed python27
graphics/py-PyX|graphics/py-pyx|2020-02-16|Use lowercase port name
misc/brs|misc/bible-kjv|2020-02-17|Match upstream name (successor to brs)
audio/decibel-audio-player||2020-02-22|Has expired: Old, uses EOLed python27
audio/soundconverter||2020-02-22|Has expired: Old, uses EOLed python27
cad/linuxcnc-devel||2020-02-22|Has expired: Broken, uses EOLed python27
databases/monetdb||2020-02-22|Has expired: Broken, uses EOLed python27
databases/py-cql||2020-02-22|Has expired: Broken, uses EOLed python27
databases/zodb3||2020-02-22|Has expired: Old, uses EOLed python27
deskutils/gourmet||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-Products.PlacelessTranslationService||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-Products.ZopeVersionControl||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-Products.statusmessages||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-collective.z3cform.datetimewidget||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-five.formlib||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-five.localsitemanager||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-notifier||2020-02-22|Has expired: Broken, uses EOLed python27
devel/py-tempstorage||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-testgears||2020-02-22|Has expired: Broken, uses EOLed python27
devel/py-z3c.caching||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-z3c.form||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-z3c.formwidget.query||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.annotation||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.applicationcontrol||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.appsetup||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.broken||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.cache||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.component||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.container||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.content||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.debug||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.dependable||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.error||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.exception||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.file||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.folder||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.form||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.generations||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.http||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.pagetemplate||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.publication||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.publisher||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.rotterdam||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.testing||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.zcmlfiles||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.app.zopeappgenerations||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.applicationcontrol||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.browsermenu||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.browserpage||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.componentvocabulary||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.container||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.copypastemove||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.dublincore||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.error||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.formlib||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.minmax||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.pagetemplate||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.ptresource||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.ramcache||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.site||2020-02-22|Has expired: Old, uses EOLed python27
devel/py-zope.viewlet||2020-02-22|Has expired: Old, uses EOLed python27
games/gcompris||2020-02-22|Has expired: Broken, uses EOLed python27
graphics/commons-utilities||2020-02-22|Has expired: Broken, uses EOLed python27
graphics/py-chart||2020-02-22|Has expired: Broken, uses EOLed python27
japanese/tegaki-recognize||2020-02-22|Has expired: Broken, uses EOLed python27
mail/py-zope.sendmail||2020-02-22|Has expired: Old, uses EOLed python27
mail/pysieved||2020-02-22|Has expired: Broken, uses EOLed python27
math/ogdf||2020-02-22|Has expired: Broken, uses EOLed python27
math/py-viper||2020-02-22|Has expired: Broken, uses EOLed python27
misc/fbless||2020-02-22|Has expired: Broken, uses EOLed python27
misc/pylize||2020-02-22|Has expired: Broken, uses EOLed python27
net/py-ldaptor||2020-02-22|Has expired: Broken, uses EOLed python27
net/tucan||2020-02-22|Has expired: Broken, uses EOLed python27
news/hellanzb||2020-02-22|Has expired: Broken, uses EOLed python27
science/coot||2020-02-22|Has expired: Broken, uses EOLed python27
science/py-ScientificPython||2020-02-22|Has expired: Broken, uses EOLed python27
security/py-cryptlib_py||2020-02-22|Has expired: Broken, uses EOLed python27
security/py-zope.app.authentication||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.app.localpermission||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.app.principalannotation||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.app.security||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.app.securitypolicy||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.authentication||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.login||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.pluggableauth||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.principalannotation||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.principalregistry||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.security||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.securitypolicy||2020-02-22|Has expired: Old, uses EOLed python27
security/py-zope.session||2020-02-22|Has expired: Old, uses EOLed python27
sysutils/gnome-schedule||2020-02-22|Has expired: Old, uses EOLed python27
sysutils/py-XenAPI||2020-02-22|Has expired: Broken, uses EOLed python27
sysutils/py-freenas.cli||2020-02-22|Has expired: Broken, uses EOLed python27
textproc/ecromedos||2020-02-22|Has expired: Broken, uses EOLed python27
textproc/py-wicked||2020-02-22|Has expired: Old, uses EOLed python27
textproc/py-zope.app.i18n||2020-02-22|Has expired: Old, uses EOLed python27
www/planet||2020-02-22|Has expired: Broken, uses EOLed python27
www/py-zope.app.wsgi||2020-02-22|Has expired: Old, uses EOLed python27
www/trac-attachmentpolicy||2020-02-22|Has expired: Broken, uses EOLed python27
www/trac-bzr||2020-02-22|Has expired: Broken, uses EOLed python27
www/trac-childtickets||2020-02-22|Has expired: Broken, uses EOLed python27
www/trac-gantt||2020-02-22|Has expired: Broken, uses EOLed python27
www/trac-tracdragdrop||2020-02-22|Has expired: Broken, uses EOLed python27
www/trac-watchlist||2020-02-22|Has expired: Broken, uses EOLed python27
www/twill||2020-02-22|Has expired: Broken, uses EOLed python27
x11/wbarconf||2020-02-22|Has expired: Broken, uses EOLed python27
x11-wm/simple-ccsm||2020-02-22|Has expired: Broken, uses EOLed python27
math/metis4|math/metis|2020-02-22|Has expired: EOL: use math/metis instead
multimedia/cinelerra-gg||2020-02-22|Has expired: Broken, uses EOLed python27
x11-toolkits/py-gnome2||2020-02-22|Has expired: Broken, uses EOLed python27
# $FreeBSD: head/Mk/Uses/cabal.mk 512795 2019-09-25 16:57:35Z arrowd $
# $FreeBSD: head/Mk/Uses/cabal.mk 526884 2020-02-23 07:30:13Z tobik $
#
# Provide support for building Haskell packages using Cabal.
#
......@@ -132,7 +132,7 @@ make-use-cabal:
# Re-generates USE_CABAL items to have revision numbers.
make-use-cabal-revs:
. for package in ${_use_cabal}
@(${ENV} HTTP_ACCEPT="application/json" fetch -q -o - http://hackage.haskell.org/package/${package:C/_[0-9]+//}/revisions/ | sed -Ee 's/.*":([0-9]+)}\]/${package:C/_[0-9]+//}_\1 /' -e 's/_0//')
@(${SETENV} HTTP_ACCEPT="application/json" fetch -q -o - http://hackage.haskell.org/package/${package:C/_[0-9]+//}/revisions/ | sed -Ee 's/.*":([0-9]+)}\]/${package:C/_[0-9]+//}_\1 /' -e 's/_0//')
@echo '\'
. endfor
......
#-*- tab-width: 4; -*-
# ex:ts=4
#
# $FreeBSD: head/Mk/Uses/gnome.mk 524409 2020-01-27 19:40:17Z rene $
# $FreeBSD: head/Mk/Uses/gnome.mk 526856 2020-02-22 20:01:41Z rene $
# $NetBSD: $
#
# Please view me with 4 column tabs!
......@@ -81,7 +81,7 @@ _USE_GNOME_ALL+= atk cairo \
libgnomecanvas libgnomekbd \
libgnomeui libgsf libgtkhtml libidl librsvg2 libwnck \
libxml2 libxslt \
orbit2 pango pangox-compat pygnome2 pygobject pygtk2 \
orbit2 pango pangox-compat pygobject pygtk2 \
pygtksourceview vte
# GNOME 3 components
......@@ -307,10 +307,6 @@ pygtk2_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pygtk-2.0.pc:x11-toolkits/p
pygtk2_RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pygtk-2.0.pc:x11-toolkits/py-gtk2
pygtk2_USE_GNOME_IMPL= libglade2 pygobject
pygnome2_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-python-2.0.pc:x11-toolkits/py-gnome2
pygnome2_RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-python-2.0.pc:x11-toolkits/py-gnome2
pygnome2_USE_GNOME_IMPL=libgnomeui pygtk2
intltool_BUILD_DEPENDS= ${LOCALBASE}/bin/intltool-extract:textproc/intltool
intlhack_PRE_PATCH= ${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${FRAMEWORK_REINPLACE_CMD} \
......
# $FreeBSD: head/Mk/Uses/xorg-cat.mk 517002 2019-11-07 18:49:58Z zeising $
# $FreeBSD: head/Mk/Uses/xorg-cat.mk 526592 2020-02-20 21:41:02Z zeising $
#
# xorg ports categories and other things needed to build xorg ports.
# This is intended only for ports of xorg and freedesktop.org applications.
......@@ -124,6 +124,7 @@ USE_XORG+= xorg-macros
. elif ${_XORG_CAT} == driver
USE_XORG+= xi xorg-server xorgproto
CFLAGS+= -Werror=uninitialized
. if ${_XORG_BUILDSYS} == meson
# Put special stuff for meson here
. else
......@@ -150,6 +151,7 @@ PLIST_FILES+= "@comment ${FONTSDIR}/fonts.dir" \
. endif
. elif ${_XORG_CAT} == lib
CFLAGS+= -Werror=uninitialized
.include "${USESDIR}/pathfix.mk"
. if ${_XORG_BUILDSYS} == meson
# put meson stuff here
......@@ -165,12 +167,15 @@ CONFIGURE_ARGS+=--enable-malloc0returnsnull
. elif ${_XORG_CAT} == xserver
DISTNAME?= xorg-server-${PORTVERSION}
CFLAGS+= -Werror=uninitialized
.include "${USESDIR}/pathfix.mk"
. if ${_XORG_BUILDSYS} == meson
# put meson stuff here
. else
CONFIGURE_ARGS+= --with-xkb-path=${LOCALBASE}/share/X11/xkb \
--with-fontrootdir=${LOCALBASE}/share/fonts
libtool_ARGS?= # empty
.include "${USESDIR}/libtool.mk"
. endif
LIB_PC_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dri.pc:graphics/mesa-dri
USE_XORG+= fontutil
......
......@@ -27,7 +27,7 @@
# If you are wondering what your port exactly does, use "make test-gcc"
# to see some debugging.
#
# $FreeBSD: head/Mk/bsd.gcc.mk 521584 2019-12-31 03:06:49Z gerald $
# $FreeBSD: head/Mk/bsd.gcc.mk 526751 2020-02-22 10:15:04Z gerald $
GCC_Include_MAINTAINER= gerald@FreeBSD.org
......@@ -82,18 +82,17 @@ _GCC_ORLATER:= true
. endif # ${USE_GCC} == any
# Initialize _GCC_FOUND${v}. In parallel, check if USE_GCC points to a
# valid version to begin with.
# See whether we have the specific version requested installed already
# and save that into _GCC_FOUND. In parallel, check if USE_GCC refers
# to a valid version to begin with.
.for v in ${GCCVERSIONS}
. if exists(${LOCALBASE}/bin/gcc${_GCCVERSION_${v}_V:S/.//})
_GCC_FOUND${v}= port
. elif ${OSVERSION} < ${_GCCVERSION_${v}_R}
. if exists(/usr/bin/gcc)
_GCC_FOUND${v}= base
. endif
. endif
. if ${_USE_GCC}==${_GCCVERSION_${v}_V}
_GCCVERSION_OKAY= true
. if exists(${LOCALBASE}/bin/gcc${_GCCVERSION_${v}_V:S/.//})
_GCC_FOUND:= ${_USE_GCC}
. elif ${OSVERSION} < ${_GCCVERSION_${v}_R} && exists(/usr/bin/gcc)
_GCC_FOUND:= ${_USE_GCC}
. endif
. endif
.endfor
......@@ -102,31 +101,9 @@ IGNORE= Unknown version of GCC specified (USE_GCC=${USE_GCC})
.endif
# If the GCC package defined in USE_GCC does not exist, but a later
# version is allowed (for example 4.7+), see if there is a later.
# First check if the base installed version is good enough, otherwise
# get the first available version.
#
# version is allowed (for example 8+), go and use the default.
.if defined(_GCC_ORLATER)
. for v in ${GCCVERSIONS}
. if ${_USE_GCC} == ${_GCCVERSION_${v}_V}
_GCC_MIN1:= true
. endif
. if defined(_GCC_MIN1) && defined(_GCC_FOUND${v}) && ${_GCC_FOUND${v}}=="base" && !defined(_GCC_FOUND)
_GCC_FOUND:= ${_GCCVERSION_${v}_V}
. endif
. endfor
. for v in ${GCCVERSIONS}